понедельник, 16 июля 2012 г.

Обновление до ЛЭРС УЧЁТ 3.0

Все основные работы по ЛЭРС УЧЁТ 3.0 завершены. В данный момент дорабатывается сопроводительная документация, лицензионное соглашение и прайс-лист.
Завтра начинается публикация обновлённой системы на нашем сайте, и уже послезавтра 18 июля ЛЭРС УЧЁТ 3.0 будет доступен для загрузки.

Процесс обновления до 3.0 не будет полностью автоматическим. Перед установкой новой системы потребуется выполнить подготовительные работы.


ОЧЕНЬ ВАЖНО! Перед обновлением коммерческой версии обратитесь к вашему поставщику ЛЭРС УЧЕТ для получения кода активации!
Для персональных версий код активации не требуется.


1. Перед обновлением обязательно сделайте резервную копию базы данных.

2. Обновите программные продукты, требуемые для работы ЛЭРС УЧЁТ 3.0. Первыми необходимо установить Microsoft .NET Framework 4.0 и Windows Installer 4.5. Причём Windows Installer 4.5 нужен только для установки SQL Server 2008 R2, который требуется если вы собираетесь установить сервер ЛЭРС УЧЁТ. Следующим шагом необходимо обновить SQL сервер. Процесс обновления сервера подробно описан в этой статье.
UPD:
В программу установки была добавлена возможность автоматического обновления SQL-сервера. Обновляется может только SQL 2005 Express и только именованный экземпляр "LERS". Для этого необходимо загрузить пакет LERS_UCHET_FULL и при установке версии 3.0 указать установку нового сервера, или выбрать существующий сервер с именованным экземпляром "LERS". В этом случае программа установки предложит вам запустить автоматическое сервера баз данных.

Для установки Microsoft .NET Framework 4.0 на Windows 2003 Server предварительно необходимо загрузить и установить компонент обработки изображений Windows (WIC). Иначе в процессе установки вы получите такое сообщение об ошибке.




3. Убедитесь, что вы помните пароль администратора для входа в ЛЭРС УЧЁТ. После обновления до версии 3.0 вам нужно будет ввести его заново, даже если он был сохранён. Если вы не помните пароль, но можете войти в систему, то сделайте это и смените пароль для своей учётной записи.

4. В ЛЭРС УЧЁТ 3.0 изменилась схема лицензирования. Количество необходимых лицензий теперь определяется количеством объектов учёта, а не количеством приборов, как в предыдущей версии. Если у вас количество созданных объектов учёта превышает количество приборов, то после установки вам может не хватить имеющихся лицензий. В таком случае обратитесь в организацию, у которой вы покупали лицензии ЛЭРС УЧЁТ, или напрямую в службу технической поддержки по электронной почте support@lers.ru. С каждым подобным случаем проблема будет решаться индивидуально.

5. После обновления вам потребуется активировать систему, введя ключ активации. Чтобы его получить вам так же нужно обратиться в организацию, у которой вы покупали лицензии.

Удалите предыдущую версию программы. Вы можете запустить программу удаления из панели управления. В случае если версия 2.XX установлена на вашей системе, программа установки версии 3.0 обнаружит это и предложит вам отменить установку или автоматически запустить удаление.

Внимание! Если вы хотите обновить существующую базу данных до версии 3.0, не удаляйте её при удалении системы. Когда программа удаления задаст вопрос: "Хотите удалить базу LERS?", выберите "Нет".

После удаления ЛЭРС УЧЁТ версии 2.XX запустите программу установки ЛЭРС УЧЁТ 3.0. Программа проверит, существует ли на SQL-сервере база данных предыдущей версии и предложит вам обновить её до последней актуальной в процессе установки.

Чистая установка ЛЭРС УЧЁТ 3.0 осуществляется практически так же как прежде.

Одно из новшеств в версии 3.0 - новая система автоматического обновления. При установке или обновлении до 3.0 вам потребуется задать параметры службы автоматического обновления. Описанию этих параметров службы будет посвящён отдельный пост.

2 комментария:

  1. Правильно ли я понимаю, что если мы ранее обновили SQL Server до 2008, то предварительная установка дополнительных компонентов не потребуется, и можно будет сразу переходить к установке ЛЭРС 3.0?

    ОтветитьУдалить
    Ответы
    1. Потребуется .NET Framework 4.0. Если он установлен, то никакое дополнительное ПО не нужно.
      В посте была небольшая неточность, поправил.

      Удалить